Back to overview
Resolved

Experian Degradation Detected

Sep 21, 2026 at 2:22pm UTC
Affected services
Experian

Resolved
Sep 21, 2026 at 3:48pm UTC

Service has recovered. StatusGator reports operational status.

Created
Sep 21, 2026 at 2:22pm UTC

StatusGator reports Experian is experiencing degraded performance.