Back to overview
Resolved

LexisNexis Risk Outage Detected

Sep 20, 2026 at 9:18am UTC
Affected services
LexisNexis

Resolved
Sep 20, 2026 at 9:29am UTC

Service has recovered. StatusGator reports operational status.

Created
Sep 20, 2026 at 9:18am UTC

StatusGator reports LexisNexis Risk is experiencing an outage.