Back to overview
Resolved
LexisNexis Risk Outage Detected
Aug 23, 2026 at 10:54am UTC
Affected services
LexisNexis
Resolved
Aug 23, 2026 at 11:04am UTC
Service has recovered. StatusGator reports operational status.
Affected services
Created
Aug 23, 2026 at 10:54am UTC
StatusGator reports LexisNexis Risk is experiencing an outage.
Affected services