Back to overview
Resolved

LexisNexis Risk Outage Detected

Aug 23, 2026 at 5:28am UTC
Affected services
LexisNexis

Resolved
Aug 23, 2026 at 7:26am UTC

Service has recovered. StatusGator reports operational status.

Created
Aug 23, 2026 at 5:28am UTC

StatusGator reports LexisNexis Risk is experiencing an outage.