Back to overview
Resolved

LexisNexis Risk Outage Detected

Aug 19, 2026 at 1:05am UTC
Affected services
LexisNexis

Resolved
Aug 19, 2026 at 1:44am UTC

Service has recovered. StatusGator reports operational status.

Created
Aug 19, 2026 at 1:05am UTC

StatusGator reports LexisNexis Risk is experiencing an outage.